BSCI Exam

Well,

I wasn’t ready for the exam. I went in fairly confident, but slightly psyched out. I ran through all of the chapter summaries and Q&A in the exam guide last night, reading sections that I wasn’t sure on. I hit up my notes, and fired up some of the gear to double check some answers on questions that I was unsure of.

I ended up with a 777/1000 on the exam this morning. passing is 790. IPv6 (specifically 6to4 tunneling) and IS-IS really hurt me. I knew I was weak on IPv6, but I didn’t realize I was THAT weak. Oh well. I’ll go back through the self study guide, and watch the trainsignal videos on IPv6 and IS-IS this week, and attempt the exam again in a few weeks.

work…

Our company was given the go ahead to be purchased today. The next few months are going to be an interesting transition. I’m anxious about it.

Otherwise, I’m continuing with studies every day/night this week. I’m going to sit BSCI on Friday morning. Even if I don’t feel like I’m 100% ready for it, I’d like to have it out of the way. I’ve been psyching myself out about this exam, and I know I’m capable.

moving right along

My wife took the baby with her to another baby shower today. She left me alone so that I could get some studying done. I dunno what happened, but I’m going to call today a wash. I struggled to focus on anything, and stay with it. I made it through another BGP video, and listened to the IPv6 video while I cleaned the apartment up a bit. All in all, I really didn’t get very far.

This next week should be pretty relaxed at work. We’re still holding our breath for some upcoming information, and all of our projects are on hold. On top of that, my boss may be going out of town on a family emergency, and my co-worker is leaving to see his mother off to London for a two year mission. Maria has told me she’s going to allow me every evening this week to study (save for thursday night, when she takes the 8 year old to see the doodle bops).

I am going to get through all of the BGP chapters in the authorized self study guide and videos on Monday. Tuesday will be spent focusing on IPv6/OPSFv3, and Wednesday on Multicast. Thursday will be review and some additional lab work just to solidify everything. I’ll make the decision to take the test this week by Wednesday. Because of the work related stuff, I MAY put it off until early the following week (which would give me one more weekend to study), but we’ll see.

In the meantime, my notes from the BGP section today:
There are two main classes of attributes in BGP: well known and optional.
Within these two classes, there are two sub-classes each:

well known: mandatory and discretionary
optional: transitive and non-transitive

well known mandatory attributes are as_path, origin, and next hop
well known discretionary attributes are local preference and atomic aggregate
optional transitive attributes are aggregator and community
optional non-transitive attributes are MED (multi-exit discriminator)

optional attributes aren’t necessarily understood by all BGP speakers. If a BGP speaker sees an optional transitive attribute that it doesn’t understand, it just forwards that information onto the next peer. Attributes that are optional non-transitive are dropped by BGP speakers that don’t understand them. Chris Bryant mentioned the partial bit for optional transitive attributes. I’d like to see the behavior for all of the above. I just don’t know how likely it is with all cisco gear.

BGP best path selection:
1. use the path with the highest weight (weight is a cisco proprietary attribute)
2. use the path with the highest local preference (this is 100 by default and is the same throughout the AS. can be assigned through the bgp default local-pref # router configuration command, or done on a per-route basis with route maps. route maps are preferred)
3. use the path that was originated locally
4. use the path with the shortest as_path
5. use the path with the best origin code (IGP is preferred over EGP is preferred over ?/incomplete)
6. use the path with the lowest MED (I think I read somewhere that Cisco uses this attribute the exact opposite of the RFC standard. I want to say the command to correct this is bgp bestpath med missing-as-worst.)
7. use eBGP path over iBGP path.
8. use the lowest IGP metric to the BGP next hop
9. use the most recent path
10. use the lowest BGP Router-ID.

I have additional notes, but They work better with diagrams and sample configs. Since I don’t have visio on my laptop yet, I’ll hold off on the diagrams for now. Besides… It’s time to get in the shower and get ready to go out tonight. This was the stipulation set on me getting to study today.

More Trainsignal

I made it through all four of the trainsignal OSPF videos from Trainsignal. I will say that I am completely impressed by Chris Bryant’s teaching and have been very happy with the products so far. My only issue has been the brief explanation he gave on stub areas/NSSA. I found his explanations of NSSA, specifically, to be a little confusing. I’m familiar with how they work and have set them up in lab scenarios, so I’m not concerned for myself… I just thought a little more time could have been spent on them. Maybe he’ll get to it a little more in depth with redistribution.

I don’t have much going on today. We’re doing some work at a remote site this evening, so we’ve been pretty relaxed today. I decided to start the BGP videos, since that’s one of the areas I’m lacking. Just as a side note… I really need to get a better PC to load dynamips on. I have a great rack at home, but I can’t afford to leave it running 24/7 (power consumption). It’d be nice to be able to load a few 2600’s on my work PC, but dynamips keeps crashing. I have a P4 1.8 with 1.5 gigs of RAM, and everytime I load a pair of 2621XM’s (for IOS 12.4), the damned server crashes.

Anyway… Some of the key points from the first hour of the BGP video were:
1. Two classes of attributes: well known and optional. (He didn’t go any further than this just yet.)
2. BGP uses TCP port 179 for communication and uses keep alives to maintain connection.
3. Full tables are exchanged during the relationship establishment. Following that, updates are only sent when a change occurs.
4. Cisco recommends that eBGP peers are directly connected, though there wasn’t any mention of whether or not this is REQUIRED. iBGP peers to not need to be directly connected.
5. BGP states:
a. idle
b. connect
c. active
d. opensent
e. openconfirm
f. established (this is what you want to see when running show ip bgp neighbor and show ip bgp summary)

ebgp_multihop.jpg
A Sample configuration for the above:

R1#conf t
R1(config)#router bgp 100
R1(config-router)#neighbor 172.12.123.3 remote-as 200

R3#conf t
R3(config)#router bgp 200
R3(config-router)#neighbor 172.12.123.1 remote-as 100

If we wanted to use loopback interfaces for additional stability (this would come into play for iBGP with multiple paths to each host, and eBGP with two direct links between peers), we would use the following:
R1#conf t
R1(config)#router bgp 100
R1(config-router)#neighbor 3.3.3.3 remote-as 200
R1(config-router)#neighbor 3.3.3.3 ebgp-multihop 2
(we use the multihop command because we are not peering with the IP address directly connected to us.  The 2 is the number of hops we need to traverse)
R1(config-router)#neighbor 3.3.3.3 update-source lo0 (this is telling the local router to use lo0 as the source of all bgp traffic.  No matter what interface we use to communicate with 3.3.3.3, we will use that Lo as the source IP. )

One of the gotchas was to make sure that we had routes to the loopback interfaces on each side. Since we’re not running an IGP between the two, we opted to use static routes. In Chris’s video, R1 and R3 were connected through a frame switch. He used the interface option in his static route, and the adjacency never came up. When he changed the static route to use the next hop, it came up.

Chris also went through some basic network information in BGP.
First and foremost, when you advertise a network in BGP, you must use the EXACT mask that you have setup or that exists in your routing table. EX:
R1#conf t
R1(config)#interface lo1
R1(config-if)#ip addr 11.11.11.11 255.255.255.255

would require the following network statement in BGP:
R1(config-router)#network 11.11.11.11 mask 255.255.255.255

whereas
R1#conf t
R1(config)#interface lo1
R1(config-if)#ip addr 11.11.11.11 255.255.255.0

would require this statement:
R1(config-router)#network 11.11.11.0 mask 255.255.255.0
The command show ip bgp on the local router will tell you if the route is being advertised to it’s peers.

I want to make it through the rest of the BGP sections and IPv6 before Saturday so I can spend the day working on these labs. My wife will be at another baby shower, and is taking the rugrat with her. I’m determined to get this exam done by Friday of next week.

trainsignal/lack of sleep

Alex Skinger from Trainsignal contacted me last week, and asked if I would be interested in checking out the BSCI/BCMSN/CCNA training materials from them. Until this point, I’ve been relying solely on Cisco Press books and reading things on the internet. I figured I’d give the VBT a try and see how I like it.

The materials showed up today, and were waiting for me when I got home from work this evening. I immediately tore through the packaging and threw the BSCI stuff into the laptop. So far, I’ve made it through the IP routing fundamentals video (just over an hour), the distance vector protocols video (somewhere in the range of 40 minutes), and the intro to OSPF video (about an hour). I have to say, I’m impressed. Chris Bryant covered some information in the DHCP server and ip helper configurations that I haven’t seen covered in three different versions of BSCN/BSCI Cisco Press books, AND the Network Academy curriculum. He’s also covered some additional details and key points in RIPv2 and OSPF that weren’t covered in the current study guides. I don’t know if that info will be on the test, but it’s good stuff to know.

I started working on the practice exams tonight, and I’m severely lacking in BGP and IPv6. I wanted to take the exam by next Friday. I’m starting to wonder if that’s enough time, or if I should postpone for a week. I guess we’ll see how my study schedule pans out for the rest of this week and weekend. I’m still fighting this flu/stomach shit that I’ve got. I’ve felt completely drained all week. By the time my lunch hour rolls around at work, I feel like I haven’t slept in days, and completely exhausted. That makes it pretty difficult to focus and study at all in the afternoons and evenings when I get home. I may just need to take a night and sleep.

route manipulation/BGP

I think I’m coming down with a stomach bug/flu. I’ve been sick all weekend, and was very lethargic all day.
Even still, I made it through the route manipulation/redistribution chapters and labs today. The labs only covered redistributing RIP into OSPF and OSPF back into RIP. nothing with RIP/EIGRP, or EIGRP/OSPF, so I just started doing my own and running lots of debugs and traces to see what might happen.
I’m going to have to read through those sections again just to make sure I’m remembering all of the differences in redistributing the protocols and all the stuff involved with route maps and distribute lists.
I got about 40 pages into the BGP stuff in the authorized self study. I’ll finish that section up this week and double it up with the network academy stuff, as well as the exam certification guide, and hit the labs next weekend. If time permits this week, I’ll hit the multicast stuff, too.

My goal is to have this exam out of the way by February 29th. From there, I don’t want to spend much more than a month or two on each additional NP exam. This is something I should have completed a long time ago, and have had too much happening over the last year to follow through with. NOW is the time.

In other news, a sales manager for Trainsignal contacted me about reviewing some of their materials this week. I live in an apartment with a gate at the entrance. I’ve been in this apartment for a year and a half, and my name still isn’t on the call box. When I found out that the management has decided to close our front gates during the day, I was a little bit miffed. Needless to say, I still haven’t received the materials. I’ve never used VBT/CBT for any tests/certs before. I’m anxious to see how well this training works out.

IS-IS

Made it through IS-IS and the labs this evening. My wife’s done a decent job of keeping the kids out of my hair long enough to get me through all of this.

I also looked through the Network Academy curriculum and chapter test for IS-IS. I ran across a question that I didn’t see covered in the authorized self study, and the answer in the Network Academy quiz seems wrong to me.

Observe the diagram. The administrator requires the IS-IS adjacencies to authenticate so that no unauthorized routers will create adjacencies. Which command is required for an area to authenticate?

A. area-password password
B. domain-password password
C. area # authentication password
D. isis password password

The diagram had R1 and R2 connected over fast ethernet with R2 connected to R3 over a serial link. It didn’t specify IP addresses or area information. According to the curriculum, the correct answer is D.
Of the four answers, A makes the most sense to me, since the question specified area authentication. B is specific to the entire routing domain, while C is slightly incorrect syntax. (the syntax would be area # authenticate snp send-only or validate). D is specific to the interface. Anyone who might read this, can you clarify for me?